java - intelliJ IDEA 13错误:请选择Android SDK

我已经在Error: Cannot find any configured Android SDK上安装了intelliJ 12.1.2Error: Cannot find any configured Android SDK。现在我使用intelliJ 13.0.1创建了一个空的android应用程序项目(也使用模拟器作为目标设备)并尝试构建项目,但遇到了'Error: Please select Android SDK'

所以我选择intelliJ 12.1.2作为intelliJ 13.0.1,但我无法选择我的AVD,因为有Error: Cannot find any configured Android SDK

在项目结构中,它清楚地将“Android 4.4.2平台”显示为Project SDK。 所以我完全糊涂了,不知道如何解决这个问题。

PS。 我正在将intelliJ 12.1.2升级到intelliJ 13.0.1,并且在启动13.0.1时所有设置都自动从12.1.2继承,但似乎并非所有设置都完全复制到13.0.1,这是意外的。

干杯

18个解决方案
144 votes

我的问题:“请选择Android SDK”,但一切都很好看:( - >我认为其中一个IntelliJ文件崩溃了(死后的蓝屏)

我的决议:

文件 - > 设置 - > Android SDK - > Android SDK位置编辑 - > 接下来,Next(Android SDK是最新的。),已完成

...和崩溃的文件被修复了!

rocciax answered 2019-06-24T17:42:21Z
67 votes

我在安装Intellij IDEA Ultimate 14.1并打开我使用Android Studio创建的现有Android项目后遇到此错误。 事实证明,我只需将Android SDK添加到我的SDK列表中并修复项目/模块SDK设置。 这就是我做的方式:

转到C:\Users\<windows username>\AppData\Local\Android\android-sdk.单击“项目设置”下的“项目”选项卡。 在Project SDK下,单击New -> Android SDK

Adding new Android SDK

现在选择Android SDK的现有目录。 在我的情况下,它在这个文件夹中:

C:\Users\<windows username>\AppData\Local\Android\android-sdk

单击确定。 弹出一个菜单,要求您设置Java SDK + Build目标。 您可以更改这些或将其保留为默认值,然后单击“确定”。 您现在应该在Project SDK下拉列表中看到“Android API XX Platform”。 单击底部的“应用”。 然后转到“项目设置”下的“模块”选项卡,然后单击模块列表中的文件夹。

Module List

对于每个文件夹,转到依赖项选项卡,将Module SDK更改为新的Android SDK,然后单击“应用”。 然后单击“确定”关闭“项目结构”对话框。

完成上述操作后,我的项目得以修复。

Christian Wilkie answered 2019-06-24T17:43:34Z
48 votes

我曾经遇到过同样的问题。 一切似乎都是对的。 我重新启动,删除和无效Android工作室的缓存,重建,清理和更改。 最后通过在android studio 3.0中点击Sync Project with Gradle Files按钮解决

Sync Project with Gradle Files button

Kenji answered 2019-06-24T17:44:01Z
32 votes

从Intellij中删除所有Android SDK并再次添加它们。

要做到这一点打开项目结构,在SDK窗格中,删除所有android SDK,单击OK。 打开项目结构并再次添加它们。

Ali answered 2019-06-24T17:44:36Z
6 votes

在android 3.1.1中,我们无法在工具中找到同步项目所以C:\Users\AndroidStudioProjects\projectname\.idea\libraries从库中删除文件并再次同步

answered 2019-06-24T17:45:03Z
5 votes

如果您无法编译项目并且有此消息:

enter image description here

转到文件 - &gt; 单击项目结构,然后转到模块部分并选择您的模块应用程序,然后在单击确定后选择编译Sdk版本和构建工具版本。

enter image description here

等到gradle同步并准备就绪!

Oscar Duarte answered 2019-06-24T17:45:45Z
3 votes

我实际上遇到了IntelliJ Idea 14中的问题。我的项目在Android Studio上运行良好。我决定继续开发IntelliJ的想法。导入项目后,我没有成功运行它,我在编辑配置框中收到类似的错误消息。基于@Ali所说的内容,我删除了所有SDK并重新安装它们但是没有用。

我打开了“项目结构”&gt;“平台设置”&gt; SDK。 我发现没有设置“Android API 21平台”的“构建目标”。 通过将其设置为我最新的SDK之一,修复了问题,我可以毫无问题地运行项目。

Hesam answered 2019-06-24T17:46:20Z
2 votes
  1. 转到项目结构(Ctrl + Alt + shift + S) - &gt; 平台设置 - &gt; SDKs - &gt; 按“加号”图标
  2. 选择“Android SDK”并输入SDK路径(例如:C:\ Program Files(x86)\ Android \ android-sdk)
  3. 应用或确定按钮
  4. 要开心
user8338220 answered 2019-06-24T17:47:08Z
1 votes

我遇到了同样的问题,当时我也从intellij Idea 12更新到13.在我的情况下,我的Android SDK的Build目标无法正确识别,它说的是“未设置”,而不是Android 2.2。 即使我选择Android 2.2并单击“应用”和“确定”,当我重新打开项目结构对话框时,它再次显示“未设置”消息。

然后我选择了另一个版本,Android 4.0这次点击申请,然后再次选择Android 2.2,点击申请。 这对我有用。

Yoo Matsuo answered 2019-06-24T17:47:45Z
1 votes

也许不是那么常见的解决方案,但对我来说重新启动IDE工作得很好。 我使用Android Studio 2.2.3。

Ispas Claudiu answered 2019-06-24T17:48:12Z
1 votes

检查app build.gradle文件中的下一行。

android {
    compileSdkVersion 25       <--- Set exist in local machine sdk version.
    buildToolsVersion '25.0.3' <--- Set exist build tools version.
}
maXp answered 2019-06-24T17:48:39Z
1 votes

文件 - &gt; 无效的缓存/重启对我来说很有用(这是第一次尝试的好)

r-hold answered 2019-06-24T17:49:06Z
1 votes

您必须从项目设置中选择构建工具版本。

  1. 选择Project App Folder
  2. 按F4或右键单击Project App Folder并打开Module设置在Properties选项卡中,从List中选择Build Tool Version

这将对我有用,我希望它会对你有所帮助。

Nilesh Panchal answered 2019-06-24T17:49:54Z
0 votes

检查是否已安装所有必需的加载项。另外,我建议你使用真正的Android手机进行调试。 它更好,它真实,更快。

Giorgos Neokleous answered 2019-06-24T17:50:21Z
0 votes

似乎很多像IDEA找不到Android SDK。

使用Android SDK安装程序后重新启动计算机?

之后,您是否已启动SDK Manager来安装Android 4.2.2 SDK?

你能查看一下Android_SDK_HOME环境变量吗?


考虑到Android SDK安装程序只是安装了Manager。 之后,您必须安装SDK(或几个)。

此外,当您在项目结构中看到“Android 4.4.2平台”时,这意味着该项目将要求该SDK。 这并不意味着已安装SDK。

Mikel Pascual answered 2019-06-24T17:51:24Z
0 votes

我遇到了类似的问题。 我不得不添加我之前使用的相同的android sdk并且它有效。

Deton answered 2019-06-24T17:51:51Z
0 votes

屏幕左下方有一个名为android monitor的按钮。 如果你有sdk的问题,它会显示你的confugure link.Change你的sdk文件夹的路径。 事情会奏效

krishna answered 2019-06-24T17:52:19Z
0 votes

我有同样的问题。我通过File-&gt; Open-&gt;其他项目解决了这个问题,然后通过这种方式切换这个项目。

user9104396 answered 2019-06-24T17:52:46Z
translate from https://stackoverflow.com:/questions/21070268/intellij-idea-13-error-please-select-android-sdk