iPhone-Xcode 6:iOS 8.1无法安装开发人员磁盘映像

每当我尝试在运行iOS 8.1的iphone上运行我的应用程序时,都会出现此错误。

无法安装开发人员磁盘映像。

用户的iPhone可能正在运行不受支持的iOS版本   通过此版本的Xcode。

我尝试重新启动mac和xcode,但问题仍然存在。

Zaxter asked 2019-10-08T06:38:16Z
8个解决方案
77 votes

Xcode 6仅包含iOS 8.0 SDK。

如果您在手机上运行iOS 8.1,则需要升级到包含iOS 8.1 SDK的Xcode 6.1。

Craig Otis answered 2019-10-08T06:38:37Z
11 votes

从App Store下载最新版本的Xcode。 我的XCode 6.1的早期版本缺少8.1 SDK。 升级到最新版本可解决此问题。

Stan James answered 2019-10-08T06:39:02Z
7 votes

重新启动手机为我清除了此问题。

它从更新到Xcode 6.1的第二天开始,电话(4s)到8.1正常运行,然后在第二天停止显示此消息。

Sam answered 2019-10-08T06:39:32Z
4 votes

如果您的项目尚未准备好在6.1中编译,那么在Xcode 6.1中打开项目,然后在6.0.1中再次打开似乎可以解决问题!

mikesalvia answered 2019-10-08T06:39:56Z
3 votes

您是否检查过应用程序的基本版本。 如果基本版本设置为8,而设备为7,则可能会出现此错误。

如果您的基本版本从我的想象中是8.1,而您的设备未更新到8.1,那么它也将无法工作。

Veeru answered 2019-10-08T06:40:26Z
0 votes

Xcode 6.4 beta无法运行iOS 8.3。 切换到Xcode 6.3解决了该问题。 然后在6.4 beta中打开它时,工作正常。

david72 answered 2019-10-08T06:40:51Z
0 votes

在将我的手机完全升级到iOS 8.3之后遇到了这个问题。 要解决此问题,必须先升级到OS X Yosemite(10.10),然后才能更新到支持该iOS版本的Xcode。

Ben Thielker answered 2019-10-08T06:41:15Z
0 votes

根据我的经验,我之前已经看到过此错误。 这意味着Xcode中的Developer Disk映像与您试图运行/开发应用程序的iOS设备中的映像不兼容。 解决此问题的最简单方法之一是更新Xcode安装。 我学到的另一个快速技巧是将“开发人员磁盘”映像版本复制到Xcode.app的目录中。

我从更新和过时的开发人员磁盘映像的各种Macbook中获得了不同版本的开发人员磁盘映像的一些副本。 您可以在线下载一些资源,将其解压缩,然后将整个目录放在Xcode的安装目录中,该目录通常位于以下位置:/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

我希望这有帮助!

warfreak92 answered 2019-10-08T06:41:54Z
translate from https://stackoverflow.com:/questions/26508036/xcode-6-ios-8-1-the-developer-disk-image-could-not-be-mounted