php-如何知道MySQLnd是否是活动驱动程序?

也许这是一个显而易见的问题,但我想确定。

我怎么知道MySQLnd是否是活动驱动程序?

我正在运行PHP 5.3和MySQL 5.1.37。在phpinfo()中,列出了mysqlnd,但仅凭此我不确定我是使用MySQLnd还是旧驱动程序...

提取phpinfo()输出

mysql
MySQL Support   enabled
Active Persistent Links     0
Active Links    0
Client API version  mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $ 

mysqli
MysqlI Support  enabled
Client API library version  mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $
Active Persistent Links     0
Inactive Persistent Links   0
Active Links    26 

mysqlnd
mysqlnd enabled
Version     mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $ 

PDO
PDO support enabled
PDO drivers     mysql

pdo_mysql
PDO Driver for MySQL    enabled
Client API version  mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $ 

我正在使用PDO,并且PDO驱动程序显示mysql ...

The Disintegrator asked 2019-11-17T20:02:12Z
6个解决方案
60 votes

这应该做的伎俩:

<?php
$mysqlnd = function_exists('mysqli_fetch_all');

if ($mysqlnd) {
    echo 'mysqlnd enabled!';
}

要检测其是否为活动的PDO驱动程序,请创建MySQL PDO对象,然后:

if (strpos($pdo->getAttribute(PDO::ATTR_CLIENT_VERSION), 'mysqlnd') !== false) {
    echo 'PDO MySQLnd enabled!';
}
Inspire answered 2019-11-17T20:02:25Z
37 votes

检查$pdo并不能真正描述您是否使用mysqli,而是说您已启用mysqli扩展。

MySQLi只是PHP早期版本中提供的$pdo扩展的更新版本。

$pdo扩展名,mysqli扩展名和PDO MySQL driver可以分别配置为使用   libmysqlclient或mysqlnd

这段代码:

<?php
$mysqlnd = function_exists('mysqli_fetch_all');

if ($mysqlnd) {
    echo 'mysqlnd enabled!';
}

不回声没有提示您没有编译/启用/安装mysqli,并且可能正在使用较旧的$pdo扩展名。

用mysqlnd与mysql和libmysqlclient检查mysqli的更好方法是执行以下操作:

<?php
if (function_exists('mysql_connect')) {
    echo "- MySQL <b>is installed</b>.<br>";
} else  {
    echo "- MySQL <b>is not</b> installed.<br>";
}

if (function_exists('mysqli_connect')) {
    echo "- MySQLi <b>is installed</b>.<br>";
} else {
    echo "- MySQLi <b>is not installed</b>.<br>";
}

if (function_exists('mysqli_get_client_stats')) {
    echo "- MySQLnd driver is being used.<br>";
} else {
    echo "- libmysqlclient driver is being used.<br>";
}

之所以可行,是因为mysqlnd提供了三个附加功能,这些功能仅在将mysqlnd用作驱动程序时才起作用。

最后,PDO检查需要首先定义$pdo变量。

$dbHost = "localhost";
$dbUser = "root";
$dbPass = "password";
$dbName = "database";

$pdo = new PDO('mysql:host='.$dbHost.';dbname='.$dbName, $dbUser, $dbPass);
if (strpos($pdo->getAttribute(PDO::ATTR_CLIENT_VERSION), 'mysqlnd') !== false) {
    echo '- PDO MySQLnd <b>is enabled</b>.<br>';
} else {
    echo '- PDO MySQLnd <b>is not enabled</b>.<br>';
}
?>
Tim Groeneveld answered 2019-11-17T20:03:30Z
10 votes

在编译时选择驱动程序(libmysql或mysqlnd),并且可以分别为mysql,mysqli和pdo_mysql指定这两个驱动程序中的每一个。

这是与mysqlnd对应的三个配置选项:

  --with-mysql[=DIR]      Include MySQL support.  DIR is the MySQL base
                          directory.  If mysqlnd is passed as DIR,
                          the MySQL native driver will be used [/usr/local]
  --with-mysqli[=FILE]    Include MySQLi support.  FILE is the path
                          to mysql_config.  If mysqlnd is passed as FILE,
                          the MySQL native driver will be used [mysql_config]
  --with-pdo-mysql[=DIR]    PDO: MySQL support. DIR is the MySQL base directoy
                                 If mysqlnd is passed as DIR, the MySQL native
                                 native driver will be used [/usr/local]


对于您的情况,对于mysql,mysqli和pdo_mysql而言,“客户端API版本”均为“ mysqlnd 5.0.5-dev”。

所以看来您在这三种情况下都使用mysqlnd。

对于PDO,您已经安装了MySQL驱动程序-并且该驱动程序是基于mysqlnd编译的。

Pascal MARTIN answered 2019-11-17T20:04:19Z
9 votes

这就是我想要的

<?php
if (extension_loaded('mysqlnd')) {
}
?>
mikeytown2 answered 2019-11-17T20:04:42Z
3 votes

也许检查这些设置是否存在? 出于某些原因,phpinfo()使它们与其他ini设置有所不同。 适用于5.4,不确定5.3。

ini_get('mysqlnd.debug') !== false
Bad Habit answered 2019-11-17T20:05:06Z
1 votes

开头的phpinfo()列出了用于编译PHP的“配置命令”。

正如他们在其他答案中指出的那样,在php安装/编译过程中,mysqlnd是2个选择中的1个(默认值)。

我的7.0.33的phpinfo配置命令是:

'./configure''--prefix = / opt / php70''--with-libdir = lib64''--enable-bcmath''--enable-calendar''--enable-dbase''--enable- exif''--enable-ftp''--enable-gd-native-ttf''--enable-intl''--enable-libxml''--enable-mbstring''--enable-pdo''- -enable-soap''--enable-sockets''--enable-sqlite-utf8''--enable-wddx''--enable-zip''--with-bz2''--with-curl'' --with-freetype-dir''--with-gd''--with-gettext''--with-gmp''--with-imap''--with-imap-ssl''--with- jpeg-dir = / usr''--with-kerberos''--with-mcrypt''--with-mhash''--with-mssql''--with-mysql = / usr''--with- mysql-sock = / var / lib / mysql / mysql.sock''--with-mysqli = / usr / bin / mysql_config''--with-openssl''--with-pdo-mysql = / usr''- -with-pdo-pgsql = / usr''--with-pgsql = / usr''--with-pdo-sqlite''--with-png-dir''--with-pspell''--with- sqlite''--with-system-tzdata''--with-tidy''--with-unixODBC''--with-xmlrpc''--with-xsl''--with-zlib'

注意--with-mysqli = / usr / bin / mysql_config''

和--enable-mysqlnd''(不在本项中,而是对5.6 php版本的读取)

--with-mysqli =指向一个目录,表示它正在使用libmysqlclient如果它是mysqlnd,那么它将使用本机驱动程序。

有关此的更多信息[http://php.net/manual/en/mysqlinfo.library.choosing.php]

(我知道这已经很老了,但是这些知识可以节省我数小时的技术支持争论,而我首先看到了这一点。)

JSG answered 2019-11-17T20:06:23Z
translate from https://stackoverflow.com:/questions/1475701/how-to-know-if-mysqlnd-is-the-active-driver