javascript

java

python

c#

android

c++

node.js

php

html

jquery

ios

reactjs

css

.net

git

ruby-on-rails

sql

c

ruby

string

CSS-Font-awesome无法在MVC5中运行bundleconfig

如果我直接参考_layouts页面中的Failed to load resource: the server responded with a status of 404 (Not Found) http://localhost:51130/fonts/fontawesome-webfont.woff?v=4.0.3。 它会工作

<link href="~/Content/font-awesome-4.0.3/css/font-awesome.css" rel="stylesheet" />

但是我在Failed to load resource: the server responded with a status of 404 (Not Found) http://localhost:51130/fonts/fontawesome-webfont.woff?v=4.0.3中使用过。图标未显示。

 bundles.Add(new StyleBundle("~/Content/css").Include(
                        "~/Content/font-awesome-4.0.3/css/font-awesome.css",
                        "~/Content/bootstrap.css",                        
                         "~/Content/body.css",
                        "~/Content/site.css",
                        "~/Content/form.css"
                     ));

而且我还观察到浏览器控制台对字体目录有错误。Failed to load resource: the server responded with a status of 404 (Not Found) http://localhost:51130/fonts/fontawesome-webfont.woff?v=4.0.3

可能是什么问题呢?

trans by 2020-02-09T04:12:46Z

ruby on rails-导入Bootstrap时nil:NilClass的未定义方法`environment'

我一直在尝试将Bootstrap导入到我的Rails应用程序中,但我不太确定出了什么问题。 我以前曾做过,但我做了“捆绑更新”并销毁了一些依赖关系(我认为)。 我似乎已经修复了所有内容……除了Bootstrap。

我试着删除并重新输入'bootstrap-sass'gem ...我真的无法弄清楚错误在哪里。

谢谢您的帮助!

宝石文件

source 'https://rubygems.org'
ruby '2.0.0'

gem 'rails', '4.0.1'
gem 'bootstrap-sass'
gem 'bcrypt-ruby', '3.1.2'
gem 'faker', '1.1.2'

group :development, :test do

  gem 'sqlite3', '1.3.8'
  gem 'rspec-rails'
end

group :test do
  gem 'selenium-webdriver', '2.35.1'
  gem 'capybara', '2.1.0'
  gem 'factory_girl_rails', '4.2.1'
  gem 'database_cleaner', github: 'bmabey/database_cleaner'
end

gem 'sass-rails'
gem 'uglifier', '2.1.1'
gem 'coffee-rails', '4.0.1'
gem 'jquery-rails', '3.0.4'
gem 'turbolinks', '1.1.1'
gem 'jbuilder', '1.0.2'

group :doc do
  gem 'sdoc', '0.3.20', require: false
end

group :production do
  gem 'pg', '0.15.1'
  gem 'rails_12factor', '0.0.2'
end

Gemfile.lock

GIT
  remote: git://github.com/bmabey/database_cleaner.git
  revision: 35bd646903fc56af185a9fa9e360c568bb56756e
  specs:
    database_cleaner (1.2.0)

GEM
  remote: https://rubygems.org/
  specs:
    actionmailer (4.0.1)
      actionpack (= 4.0.1)
      mail (~> 2.5.4)
    actionpack (4.0.1)
      activesupport (= 4.0.1)
      builder (~> 3.1.0)
      erubis (~> 2.7.0)
      rack (~> 1.5.2)
      rack-test (~> 0.6.2)
    activemodel (4.0.1)
      activesupport (= 4.0.1)
      builder (~> 3.1.0)
    activerecord (4.0.1)
      activemodel (= 4.0.1)
      activerecord-deprecated_finders (~> 1.0.2)
      activesupport (= 4.0.1)
      arel (~> 4.0.0)
    activerecord-deprecated_finders (1.0.3)
    activesupport (4.0.1)
      i18n (~> 0.6, >= 0.6.4)
      minitest (~> 4.2)
      multi_json (~> 1.3)
      thread_safe (~> 0.1)
      tzinfo (~> 0.3.37)
    arel (4.0.2)
    atomic (1.1.15)
    bcrypt-ruby (3.1.2)
    bootstrap-sass (3.1.1.0)
      sass (~> 3.2)
    builder (3.1.4)
    capybara (2.1.0)
      mime-types (>= 1.16)
      nokogiri (>= 1.3.3)
      rack (>= 1.0.0)
      rack-test (>= 0.5.4)
      xpath (~> 2.0)
    childprocess (0.5.1)
      ffi (~> 1.0, >= 1.0.11)
    coffee-rails (4.0.1)
      coffee-script (>= 2.2.0)
      railties (>= 4.0.0, < 5.0)
    coffee-script (2.2.0)
      coffee-script-source
      execjs
    coffee-script-source (1.7.0)
    diff-lcs (1.2.5)
    erubis (2.7.0)
    execjs (2.0.2)
    factory_girl (4.2.0)
      activesupport (>= 3.0.0)
    factory_girl_rails (4.2.1)
      factory_girl (~> 4.2.0)
      railties (>= 3.0.0)
    faker (1.1.2)
      i18n (~> 0.5)
    ffi (1.9.3)
    hike (1.2.3)
    i18n (0.6.9)
    jbuilder (1.0.2)
      activesupport (>= 3.0.0)
    jquery-rails (3.0.4)
      railties (>= 3.0, < 5.0)
      thor (>= 0.14, < 2.0)
    json (1.8.1)
    mail (2.5.4)
      mime-types (~> 1.16)
      treetop (~> 1.4.8)
    mime-types (1.25.1)
    mini_portile (0.5.2)
    minitest (4.7.5)
    multi_json (1.9.0)
    nokogiri (1.6.1)
      mini_portile (~> 0.5.0)
    pg (0.15.1)
    polyglot (0.3.4)
    rack (1.5.2)
    rack-test (0.6.2)
      rack (>= 1.0)
    rails (4.0.1)
      actionmailer (= 4.0.1)
      actionpack (= 4.0.1)
      activerecord (= 4.0.1)
      activesupport (= 4.0.1)
      bundler (>= 1.3.0, < 2.0)
      railties (= 4.0.1)
      sprockets-rails (~> 2.0.0)
    rails_12factor (0.0.2)
      rails_serve_static_assets
      rails_stdout_logging
    rails_serve_static_assets (0.0.2)
    rails_stdout_logging (0.0.3)
    railties (4.0.1)
      actionpack (= 4.0.1)
      activesupport (= 4.0.1)
      rake (>= 0.8.7)
      thor (>= 0.18.1, < 2.0)
    rake (10.1.1)
    rdoc (3.12.2)
      json (~> 1.4)
    rspec-core (2.14.8)
    rspec-expectations (2.14.5)
      diff-lcs (>= 1.1.3, < 2.0)
    rspec-mocks (2.14.6)
    rspec-rails (2.14.1)
      actionpack (>= 3.0)
      activemodel (>= 3.0)
      activesupport (>= 3.0)
      railties (>= 3.0)
      rspec-core (~> 2.14.0)
      rspec-expectations (~> 2.14.0)
      rspec-mocks (~> 2.14.0)
    rubyzip (0.9.9)
    sass (3.3.2)
    sass-rails (4.0.1)
      railties (>= 4.0.0, < 5.0)
      sass (>= 3.1.10)
      sprockets-rails (~> 2.0.0)
    sdoc (0.3.20)
      json (>= 1.1.3)
      rdoc (~> 3.10)
    selenium-webdriver (2.35.1)
      childprocess (>= 0.2.5)
      multi_json (~> 1.0)
      rubyzip (< 1.0.0)
      websocket (~> 1.0.4)
    sprockets (2.12.0)
      hike (~> 1.2)
      multi_json (~> 1.0)
      rack (~> 1.0)
      tilt (~> 1.1, != 1.3.0)
    sprockets-rails (2.0.1)
      actionpack (>= 3.0)
      activesupport (>= 3.0)
      sprockets (~> 2.8)
    sqlite3 (1.3.8)
    thor (0.18.1)
    thread_safe (0.2.0)
      atomic (>= 1.1.7, < 2)
    tilt (1.4.1)
    treetop (1.4.15)
      polyglot
      polyglot (>= 0.3.1)
    turbolinks (1.1.1)
      coffee-rails
    tzinfo (0.3.39)
    uglifier (2.1.1)
      execjs (>= 0.3.0)
      multi_json (~> 1.0, >= 1.0.2)
    websocket (1.0.7)
    xpath (2.0.0)
      nokogiri (~> 1.3)

PLATFORMS
  ruby

DEPENDENCIES
  bcrypt-ruby (= 3.1.2)
  bootstrap-sass
  capybara (= 2.1.0)
  coffee-rails (= 4.0.1)
  database_cleaner!
  factory_girl_rails (= 4.2.1)
  faker (= 1.1.2)
  jbuilder (= 1.0.2)
  jquery-rails (= 3.0.4)
  pg (= 0.15.1)
  rails (= 4.0.1)
  rails_12factor (= 0.0.2)
  rspec-rails
  sass-rails
  sdoc (= 0.3.20)
  selenium-webdriver (= 2.35.1)
  sqlite3 (= 1.3.8)
  turbolinks (= 1.1.1)
  uglifier (= 2.1.1)
trans by 2020-02-07T21:46:37Z

滚动后更改导航栏颜色?

如何设置没有背景色的导航栏?

div后向下滚动时,导航栏将获得新的背景色(导航栏应固定在顶部,我在Bootstrap中使用navbar-fixed-top

我已经尝试了一些教程,但没有成功。

这是网站:[http://attafothman.olympe.in/]
我说的是顶部的黑色导航栏。

trans by 2020-02-06T14:16:17Z

javascript-Twitter Bootstrap按钮组控制单选按钮/复选框

我正在尝试使用Twitter Bootstrap按钮组作为一组实际的表单输入控件。 默认情况下,可以使这些按钮组像单选按钮或复选框组一样工作,但是由于它们使用<button>元素,因此实际上不能像单选按钮或复选框那样使用它们。

在我的研究中,我发现该站点使用CSS来使这些引导按钮实际上控制单选按钮和复选框。 唯一的问题是,它们使用CSS的最新功能才能工作,因此需要IE9或更高版本才能工作。

我想扩展对IE8的支持。 是否有另一种(也许受JS控制)解决方案,可以提供与上述链接相同的功能,而又没有苛刻的CSS要求?

感谢您的时间。

trans by 2020-02-05T20:34:29Z

如何使引导导航链接无效

我将引导导航栏用于向导进度指示器。 我想确保尚未单击的向导步骤不可单击。 我希望它们显示在导航栏中,但请将它们显示为灰色并禁用链接。 可以在引导导航栏中完成吗?

trans by 2020-02-04T20:43:55Z

javascript-选中复选框时动态更改引导进度栏值

我正在尝试使用引导进度条制作一个动态清单。 这是我的标记代码

<div class="progress progress-striped active">
    <div class="progress-bar" role="progressbar" aria-valuenow="0" aria-valuemin="0" aria-valuemax="100">
    </div>
</div>
<div class="row tasks">
    <div class="col-md-6">
        <p><span><?php echo $title; ?></span><?php echo $description; ?></p>
    </div>
    <div class="col-md-2">
        <label><?php echo $date; ?></label>
    </div>
    <div class="col-md-2">
        <input type="checkbox" name="progress" class="progress" value="<?php echo $progress; ?>">
    </div>
    <div class="col-md-2">
        <input type="checkbox" name="done" class="done" value="<?php echo $done; ?>">
    </div>
</div><!-- tasks -->

我要做的是,当我选中第一个复选框时,进度条值将更改为复选框值,而当我选中第二个复选框时,进度条值必须以第二个复选框值递增,依此类推

这是我的JavaScript代码

$(document).ready(function() {
  $('.progress').change(function(event) {
    var progress_value = $(this).val();
    var newval = progress_value;
    if ($(this).is(':checked')) {
      $('.progress-bar').css("width", function(i) {
        while(newval < 100) {
          return newval+"%";
          newval+=progress_value;
        }
      });
    } else {
      $('.progress-bar').css("width", function(i) {
        do {
          newval -= progress_value;
          return newval+"%";
        } while(newval >= progress_value);
      });
    }
  });
});
trans by 2020-02-03T18:49:29Z

CSS-使用Twitter Bootstrap 2.0-如何使列高相等?

bootstrap 2.0是否有任何帮助程序使.span1,.span2 .... span12的高度相等。 我已经嵌套了这种类型的html

<div class='container'>
  <div class='row'>
    <div class='span2'>
      <div class='well'>
        XXXX
      </div>
    </div>
    <div class='span2'>
      <div class='well'>
        XXXX
        XXXX
      </div>
    </div>
    <div class='span2'>
      <div class='well'>
        XXXX
        XXXX
        XXXX
      </div>
    </div>
  </div>
</div>

如果可能,我希望每口井的高度都一样吗?

trans by 2020-02-03T15:22:56Z

javascript-如何使用Twitter Bootstrap中的弹出窗口显示图像?

Twitter Bootstrap的弹出功能的典型示例是带有标题的类固醇的工具提示。

HTML:

<a href="#" id="blob" class="btn large primary" rel="popover" data-content="And here's some amazing content. It's very engaging. right?" data-original-title="A title">hover for popover</a>

JS:

<script>
$("#blob").popover({offset: 10});
</script>

我想使用弹出框显示图像。 这可能吗?

trans by 2020-02-03T10:06:40Z

html-如何将Bootstrap Glyphicon放在ASP.Net中的asp:Button中?

我在项目中使用Bootstrap 3,并且想在ASP.net按钮中使用Bootstrap Glyphicons。

这是我使用的代码,尽管没有奏效(我得到了一个使用Twitter Bootstrap <span>标签而不是<i>标签的示例):

<asp:Button ID="btnRandom"
    runat="server"
    Text="<span aria-hidden='true'
        class='glyphicon glyphicon-refresh'>
        </span>"
    onclick="btnRandom_Click" />

也许应该做些额外的事情。

我如何使它工作? 预先感谢您的答复。

trans by 2020-02-02T14:25:35Z

bootstrap.css:.container:显示标签之前

在bootstrap.css中

您可以从Github或[http://twitter.github.com/bootstrap/#]中找到

为什么使用:

.container:before, .container:after {
  display: table;
  content: "";
  zoom: 1;
  }

  .row:before, .row:after {
   display: table;
   content: "";
   zoom: 1;
   }

为什么要在.container:before / after和.row:before / after中定义display:table?

trans by 2020-02-01T06:23:11Z

我可以将bootstrap 3与jQuery Mobile一起使用吗?

我已经阅读了许多“ bootstrap vs. jQuery mobile”文章。 很明显,它们都有不同的目标。 那么如何将它们结合起来呢?

除其他外,我喜欢引导程序的响应式布局功能。 另一方面,我也喜欢“页面”方法以及jQuery mobile(包括滑动事件等)和过渡的可能性。

是否有将两者结合的专业项目? 还是有人试图这样做却失败了?

我知道在jQuery Mobile中使用Bootstrap看起来像一个类似的问题,但是它已经过时了(请参阅bootstrap 2)。

trans by 2020-01-28T02:46:07Z

html-带下拉菜单的Twitter Bootstrap内联输入

我正在尝试显示带有下拉按钮的文本输入。 我不知道如何做到这一点。 这是我尝试过的HTML(我将其全部放在一行中没有任何结果):

<div class="input-append">
  <input type="text" placeholder="foo" class="input-mini">
  <div class="btn-group">
    <a id="amount_type" class="btn dropdown-toggle" data-toggle="dropdown" href="#">10<span class="caret"></span></a>
    <ul id="amount_type_options" class="dropdown-menu">
      <li class="selected"><a href="#">10</a></li>
      <li><a href="#">100</a></li>
      <li><a href="#">1000</a></li>
    </ul>
  </div>
</div>

这可能吗?

谢谢

trans by 2020-01-28T00:09:38Z

CSS-如何在Bootstrap 3中获得响应按钮

我正在使用bootstrap 3,并且具有以下html:

<div class="col-sm-2" >
    <a id="new-board-btn" class="btn btn-success" >Create New Board</a>
</div>

在小屏幕上,“创建新板”文本太长而无法容纳在按钮上。 我想将文本换行到另一行,并希望按钮的高度增加以适合文本。 有关如何执行此操作的任何提示?

trans by 2020-01-27T21:42:36Z

CSS-Twitter Bootstrap 3 Input-Group-Addon大小不一样

基本上,我有几个输入字段,它们的前面带有一些文本。 当我尝试在input-group-addon和输入字段本身上设置col-lg-4和col-lg-8时,它没有执行我期望的操作并调整它们的大小。

<div class="input-group">
   <span class="input-group-addon">some text</span>
   <input type="text" class="form-control" id="current_pwd" name="current_pwd" />
</div>

谁能帮助我让input-group-addon获得相同的大小?

我在这里创建了一个小提琴:[http://jsfiddle.net/Dzhz4/]解释了我的问题。

有人可以请教一下吗?

trans by 2020-01-26T10:25:58Z

html-在Bootstrap中禁用控件

我在应用程序中使用Bootstrap CSS和JS。 偶然我点击了一个禁用的下拉列表,发现它正在打开下拉列表。 我在select元素的属性中将其设置为readonly="true"

<select id="xxx" name="xxx" class="input-medium" readonly>

我也尝试设置readonly="true",但仍然相同。

但是,如果您不使用jQuery.datepicker,则文本框控件可以正常工作。

使用引导程序时,是否有一种特殊的方式将下拉控件设为只读?

trans by 2020-01-25T10:40:50Z

javascript-如何将Twitter Bootstrap Popover保持打开状态,直到鼠标移入它为止?

我有一个使用Twitter Bootstrap Popover版本1.3.0的链接来显示一些信息。 该信息包括一个链接,但是每次我将鼠标从该链接移动到弹出窗口时,弹出窗口都会消失。

如何保持弹出窗口打开足够长的时间,以使鼠标能够移入弹出窗口? 然后,当鼠标移出链接和弹出窗口时,将其隐藏吗?

还是有其他插件可以做到这一点?

trans by 2020-01-24T01:05:23Z

html-禁用Bootstrap中的链接

第一个示例不起作用。 我需要始终有一个列表来禁用链接吗? 还是我的第一个演示有什么问题?

<a class="disabled" href="#">Disabled link</a>

<ul class="nav nav-pills">
  ...
  <li role="presentation" class="disabled"><a href="#">Disabled link</a></li>
  ...
</ul>

[https://jsfiddle.net/7y0u2amy/]

trans by 2020-01-24T00:23:49Z

更改Twitter Bootstrap模式中的背景颜色?

在Twitter引导程序中创建模态时,是否可以更改背景颜色? 完全删除阴影?

注意:对于删除阴影,此操作不起作用,因为它还会更改单击行为。 (我仍然希望能够在模态外部单击以将其关闭。)

$("#myModal").modal({
  backdrop: false
});
trans by 2020-01-23T20:44:15Z

node.js-Bootstrap中的Grunt依赖项冲突

我已经从官方网站上下载了Bootstrap源文件,并且在使用节点的npm install -g grunt-cli安装项目时遇到了依赖冲突。我的机器上安装了npm install,但是一些bootstrap依赖需要0.4.0和一些0.4.1

npm install -g grunt-cli命令执行没有任何问题。 这是我执行npm install命令后得到的日志:

npm ERR! peerinvalid The package grunt does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer grunt-banner@0.2.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-contrib-clean@0.5.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-concat@0.3.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-connect@0.6.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-copy@0.5.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-csslint@0.2.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-cssmin@0.7.0 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-contrib-jade@0.9.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-contrib-jshint@0.8.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-less@0.9.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-qunit@0.4.0 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-uglify@0.3.3 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-watch@0.5.3 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-csscomb@2.0.1 wants grunt@~0.4.2
npm ERR! peerinvalid Peer grunt-exec@0.4.3 wants grunt@~0.4
npm ERR! peerinvalid Peer grunt-html-validation@0.1.13 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-jekyll@0.4.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-jscs-checker@0.3.2 wants grunt@0.4.2
npm ERR! peerinvalid Peer grunt-saucelabs@5.0.1 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-sed@0.1.1 wants grunt@~0.4

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install"
npm ERR! cwd C:\Users\\Desktop\bootstrap-3.1.1
npm ERR! node -v v0.10.15
npm ERR! npm -v 1.3.5
npm ERR! code EPEERINVALID
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     C:\Users\\Desktop\bootstrap-3.1.1\npm-debug.log
npm ERR! not ok code 0

我正在按照以下安装步骤进行操作。

如何干净地安装此项目,没有任何错误?

trans by 2020-01-23T05:13:16Z

javascript-如何将twitter引导工具提示添加到图标

我会从twitter bootstrap中向图标元素添加一个右工具提示。

代码是这样的:

<h3>Sensors Permissions <i class="icon-info-sign"></i></h3>

我希望当光标位于图标上时,会显示带有一些信息的正确工具提示...

我能怎么做? 仅包含tooltip.js librery并在图标代码中添加元素还不够吗? 我很困惑。

谢谢。

trans by 2020-01-22T17:36:53Z

上一页 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 下一页 共27页